27 janeiro 2015
# Tags
Follow Us

Como calcular intervalos de datas em dias úteis usando o Excel

Formação Power BI

Outubro 2021
  • Live streaming
  • Lisboa
  • Porto
02 February, 2021

A sua empresa precisa de calcular intervalos de datas em dias úteis? Então precisa conhecer a função DIATRABALHO – (WORKDAY)


A Função DIATRABALHO retorna o número de série de uma data antes ou depois de um número específico de dias úteis.

  • Vamos imaginar que uma determinada empresa estabelece prazos para a concretização dos seus projetos;
  • Os prazos, em dias úteis, são definidos pelo utilizador que regista os projetos numa tabela Excel;
  • Abra o livro prazos em dias úteis início.xlsx no link abaixo.

Note que este livro tem duas folhas: a folha PROJETOS e a folha FERIADOS. No intervalo A1:A18 da folha feriados, estão registados os feriados para os anos de 2015 e 2016. Se no seu caso, existem feriados regionais, terá de rever o intervalo de feriados para os inserir.

Na célula E5 - folha Projetos - vamos calcular a data em que o projeto deverá estar concluído, tendo em conta que o prazo para a conclusão é de 45 dias úteis a partir do dia 27/01/2015:

Selecione a célula E5 e digite a função:

= DIATRABALHO(C5;D5;FERIADOS!$A$1:$A$18)

Se a sua versão de Excel é a inglesa, então a fórmula será:

=WORKDAY(C5,D5,FERIADOS!$A$1:$A$18)

Se a função DIATRABALHO devolveu o número 42.094. isso significa que a célula de destino (E5) está configurada como geral.

Devolveu o número de série da data, e deverá ser configurada com o tipo de dados Data Abreviada, para assim devolver o resultado 31/03/2015.

Antes de copiar a função DIATRABALHO(C5;D5;FERIADOS!$A$1:$A$18) para o intervalo E5:E1000 vamos alterar a sintaxe para evitar que seja devolvida uma mensagem de erro caso não existam valores nas células C5 e D5, sendo assim, altere a função para:

=SE(OU(C5="";D5="");"";DIATRABALHO(C5;D5;FERIADOS!$A$1:$A$18))

Agora é necessário copiar esta fórmula para o intervalo E5:E1000. Considerando que ainda não existem valores à esquerda, fazer duplo clique no ponto de preenchimento automático da célula E5, não resultaria, por isso, vamos utilizar uma técnica diferente:

Na caixa de nomes digite o intervalo E5:E1000 e prima Enter;

Defina o tipo de dados desse intervalo como Data Abreviada, e prima em simultâneo o conjunto de teclas Ctrl d (Control d copia a formula para todo o intervalo selecionado).

intervalo datas

  1. Comentários (0)

  2. Faça o seu comentário
Ainda não existem comentários a este artigo

Deixe os seus comentários

  1. A comentar como convidado. Registe-se ou faça login para aceder à sua conta.
0 Characters
Anexos (0 / 3)
Share Your Location

Assine a nossa newsletter e receba o nosso conteúdo diretamente no seu email